Libgdx my game is just black after splash screen using ios 11

Hey everyone,

my game worked quite fine with ios-moe all the time. Now with ios 11 I wanted to update my game. Problem is as soon as I launch it with Xcode it installs fine and says “success without errors” and starts the game. I can see the splash screen and then just black with the battery icon and thats it. The game is running no errors in debug log just black nothing happens … I hope you have any ideas. Did I missed something that is now needed to configured for ios 11 maybe?


gdxVersion = ‘1.9.8-SNAPSHOT’

Dear @Rainware,

Did u used any proguard ?


proguardLevel “all”

my proguard.conf looks like that

-keep class com.badlogic.** { ; }
-keep enum com.badlogic.
* { *; }

-keep public class net.rainware.** { ; }
-keepclassmembers public class net.rainware.
* { ; }
-keep enum net.rainware.
* { ; }
-keep class com.badlogic.
* { ; }
-keep enum com.badlogic.
* { *; }

-keep class**
-keep class** {*;}
-keep class**
-keep class**
-dontwarn org.onepf.oms.appstore.FortumoBillingService

Thanks for the tip already I tried proguard “app” and everything works fine! So I will need to identify the classes

You need to use the moe-gradle version 1.4.+

Put this in your gradle file.
classpath group: ‘org.multi-os-engine’, name: ‘moe-gradle’, version: ‘1.4.+’

Look at this topic for some issues you might run into and how to solve them: