Home Features Docs Blog Support GitHub

Android Studio compile worked last week. Execution failed for task ':ios:moeLaunch'


(Dave Kittredge) #1

Hi, I am getting an error this week. The app runs on Xcode, and was running last week on Android Studio. I have tried restarting the Mac, Android Studio and Xcode.

FAILURE: Build failed with an exception

  • What went wrong:
    Execution failed for task ‘:ios:moeLaunch’.

/Users/david/AndroidStudioProjects/project/ios/build/moe/xcodebuild/XcodeBuild-main-debug-iphonesimulator.properties (No such file or directory)

Listing of directory:
ll ios/build/moe/
total 8
-rw-r–r-- 1 david staff 0 Apr 2 13:24 XcodeInternal.log
drwxr-xr-x 11 david staff 374 Apr 2 13:24 main
drwxr-xr-x 2 david staff 68 Apr 3 08:23 reports
lrwxr-xr-x 1 david staff 40 Apr 2 13:24 sdk -> /Users/david/.moe/moe-sdk-1.4.2
(no xcodebuild directory)

find . -name “XcodeBuild-main-debug-iphonesimulator.properties” shows zero results

Xcode Version 9.3 (9E145)

Android Studio 3.1
Build #AI-173.4670197, built on March 21, 2018
JRE: 1.8.0_152-release-1024-b01 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.13.3

moe-sdk 1.4.2 (I tried to uninstall and reinstall in Studio).

iOS build.gradle has dependencies section with:
classpath group: ‘org.multi-os-engine’, name: ‘moe-gradle’, version: ‘1.4.3’

IOS is set to run on iPhone 5s (IOS 11.3) in both Xcode and Android Studio “Run As”

Is there a way to get around this issue? Maybe change a config file somewhere, or what values do I put in XcodeBuild-main-debug-iphonesimulator.properties?

Thanks!


(Roland Vigh - Migeran) #2

Hi!

We are looking into this.

Best Regards,
Roland


(Roland Vigh - Migeran) #3

Hi!

We releaesed a new version of the AS / IntelliJ Plugin (1.4.3). It now supports Android Studio 3.1. You will see, that there is a new ‘Run Multi-OS Engine Gradle’ step added to the before launch setting of the run configuration.

This was required to fix Android Studio.

Best Regards,
Roland


#4

Roland, How do we upgrade to 1.4.3? Does AS automatically update the plugin? (mine still shows 1.3.0-beta2)


(Dave Kittredge) #5

Thanks Roland. It worked perfectly. I am back up and running!

For others, this is what I did on the Mac in Android Studio:
Android Studio --> Preferences --> Plugins
Right-Click on Multi-OS Engine Plugin, and select upgrade (Android Studio will require a restart)

I selected the Run button and everything compiled correctly.

Thanks again!

Dave