Home Features Docs Blog Support GitHub

MOE SDK & Gradle Plugin Community Edition release 1.5.0

I’ve been using the newest Android Studio all the time and it works like a charm :slight_smile:

1 Like

i ll give it a try then and update to the newest version !
Is there anything special to adjust in the gradle files?
That’s what i use now: classpath ‘com.android.tools.build:gradle:3.3.2’

If you use a version control (git) for your project nothing can go wrong :slight_smile: If it does not work out for you, revert the changes

@Noisyfox Thank you so much for your effort! I really appreciate it!

I get the following error:

> Configure project :ios
Using already downloaded SDK: /Users/hpbaxxter/.moe-community/moe-sdk-1.5.0
Could not resolve: multi-os-engine:moe-core:1.5.0
Could not resolve: multi-os-engine:moe-ios:1.5.0
Could not resolve: multi-os-engine:java8support:1.5.0
Could not resolve: multi-os-engine:moe-ios-junit:1.5.0
Could not resolve: multi-os-engine:moe-core:1.5.0
Could not resolve: multi-os-engine:moe-ios:1.5.0
Could not resolve: multi-os-engine:java8support:1.5.0
Could not resolve: multi-os-engine:moe-ios-junit:1.5.0
Could not resolve: multi-os-engine:moe-core:1.5.0
Could not resolve: multi-os-engine:moe-ios:1.5.0
Could not resolve: multi-os-engine:java8support:1.5.0
Could not resolve: multi-os-engine:moe-ios-junit:1.5.0

Anyone has an idea about what I am doing wrong?
I only get this error on my Mac…not on my linux machine.

You probably want to clean your project and reload your cache in Android Studio:

> Build > Clean Project

and then:

> File > Invalidate Caches / Restart

sadly I already tried this and this didn’t help :confused:

Which gradle version were you using?

@Noisyfox I use Gradle verison 6.1.1, Android gradle plugin-version 4.0.0-beta03

Could you try gradle 5.4.1 and see if that solves the problem?

@Noisyfox I will try to manage. Problem is, that I need to use gradle 6.1.1 because of other dependencies requiring this gradle verison.

@Noisyfox Okay, this fixed it. I made the mistake of using a too new version of Android-Studio forcing me to use the newer gradle version.

Which android studio version were you using? I’m using 3.6.1 which is the latest stable version and it still support gradle 5.
Or did you mean android gradle plugin version? If so, I’d suggest you to try the latest stable version which is 3.6.0 with gradle 5.6.4.

Meanwhile I’ll take a look at the compatibility with gradle 6 when I get some time.

great job!!! any plan to support swift in future? instead of Obj-C. Thanks again for your hard work!

1 Like

Thank you @Noisyfox, I believe this version has fixed my missing framework issue. I’m very grateful for you and everyone’s work involved in getting that bug fixed, and the other improvements that have been made to this plugin. Great job!

2 Likes

Currently it’s possible to bind to swift classes and methods with the @objc annotation. I’ll have a look to see if we could support normal swift classes.

1 Like

Is there a complete guide how to add obj-c or swift classes/pods etc, for people who are not so expiriensed or newbies??

1 Like

@yarnee
I would appreciate this too. I once tried to get a swift library working with this apporach, but failed somehow.

It may be the wrong thread, but hope the community will write such a guide to help others. At the moment, i do try to convert code from obj-C to java, as soon as it’s possible. But this is struggle.

Please review this pull request that fixed builds with gradle v6 for us (tested 6.0 and 6.3).

4 Likes

Thanks! I’ve publish the 1.5.1 which contains your fix.

1 Like