App rejected on "Invalid Bundle Structure" when started using Swift code


We’ve recently started including Swift code in our MOE app (along with existing obj-c code), and when we tried to upload it to the app store it got rejected in Application Loader with this error:

It seems like Apple don’t like the swift libraries in the app bundle for some reason.

Is this MOE related? Do you know how to solve this?

Thank you,

There seems to be some information about this error online here:

Under "Annoying “libswiftRemoteMirror.dylib” "

And there is a suggestion there on how to solve it, it involves adding some arguments to the xcodebuild command.
How can we do this with the MOE gradle ipa build task?

Thanks, we are working on a fix:

Dear Alex,

a possible workaround is (while we update moeIpaBuild to fix this), to use xcodebuild archive after a moeIpaBuild directly.

Best Regards,

I don’t understand what you mean, moeIpaBuild creates an IPA, and xcode archive runs on the source code… So how can I run one after the other?..
What I am doing now as a workaround is creating the IPA using the Product > Archive menu on my machine locally (instead of using our Jenkins products created with moeIpaBuild). (This is not an ideal situation obviously)
Is that what you mean?