Binding Error in iOS 12

I am using MOE 1.4.2 with iOS 12.

when I create Binding, I have some error like below.

/Applications/ error: attributes may not be specified on a category.

When I do this for iOS 11, I can bind.

How can I bind in iOS 12?

1 Like

Hi there,

I am having the exact same error, and after searching the whole internet I decided to post my own thread, then I saw yours. I hope people from Multi-OS engine can help us.


P.D: In my case I can’t bind in any iOS version. It was by default in 9.2, I doesn’t matter what version I select in Xcode, I can’t bind. Is there another way to change the version?

Well, I think we just have to wait for iOS 12 support.

Hi there,

I don’t have a solution but an information. I have the same error but I can build my project with no errors. So at least in my case this error creates no other problems.

I have the error as well but indeed it does not prevent from generating the bindings.

Ok, well, I will try it. Thanks for your info.

So can you just ignore the error? I got it twice…

Not sure about that, I have downgraded Xcode in order to write an example software. I will upgrade it once again and see what happens.