Bound class not called

Hi there. When I create my bindings to the .h file and I run the app, the class is not being called at all. I have tried placing breakpoints with no success. Am I missing any step? I have reviewed the documentation and can’t find anything. Thanks.

Ok, I found the solution if anyone comes to this issue. No matter what the binding generator generates, at the beginning of the bound class you must place the following annotations (you must remove current placed annotations, otherwise it won’t work):

@ObjCClassName("[Name of the class]")

1 Like

You saved my a**!
I was beating my head to the wall and now I made it work!!
By the way, sometimes, it works even without using that, do you know why?

This is an example (not mine)

Hey, I am glad to hear that. Well, no, I have no idea why, but I think it depends on the Multi-OS Engine version. I had to mix code from old tutorials, old documentation, well, I really had a time on it.

Consider that, in the project I sent you, there’s the class “GADBannerView” that works without this, instead, “GADInterstitial” needs this, so I can’t really understand when and why you need that.
The project was executed with the same moe version, so i don’t think is that the problem

I see. Well, no idea then. :frowning: