Can't upload ipa to app store with gradle moeIpaBuild in version 1.3.6 - provisioning profile error

I’ve upgraded moe to 1.3.6 (from 1.2.+) and now I can’t upload the ipa created with gradle moeIpaBuild to app store .
It fails on provisioning profile…
I’ve specified the dev team, signing identity , provisioning profile uuid and main scheme in the gradle script.

This is the error I get in Application Loader:

ERROR ITMS-90161: “Invalid Provisioning Profile. The provisioning profile included in the bundle media.muvix.wave [Payload/] is invalid. [Missing code-signing certificate]. A Distribution Provisioning profile should be used when submitting apps to the App Store. For more information, visit the iOS Developer Portal.”

Anybody able to do this?


Please, you try with build.gradle settings

moe {

    ipaExport {
        // (String) Describes how Xcode should export the archive. Available options: app-store, ad-hoc, package,
        // enterprise, development, and developer-id. The list of options varies based on the type of archive. Defaults
        // to development.
        method 'app-store'

Best Regards,

1 Like

Hi Roland,

Thank you, I was able to upload to app store with this new configuration.

But the IPA size is twice larger than with MOE 1.2.+

Previously it was 45MB and now it’s 82MB…

I am using -Pmoe.proguardLevel=all command line parameter like before.

When I build with moe.ipaExport.method = “development” then the IPA size is the same as before.
Only with “app-store” it is 82MB.

Is this a bug?

Actually the size that appears in TestFlight is the same as before (almost), just the size of the ipa file on my local machine is bigger. Weird.
I guess if the size for end users is the same then it’s ok…

Hi Roland,

Unfortunately, debugging from IntelliJ still isn’t working… (which was the whole point of upgrading to 1.3.+)

Actually, It worked the first time I ran it with 1.3.6 and after that it never worked again.

Like before (in 1.2.+) it is stuck on the Launching stage… “JDWP will wait for debugger on port 8000”

I tried with our app, and with a new MOE project from the IntelliJ template.

You said you fixed this in 1.3, but it’s still not working for me.

Any help would be appreciated.


Which Multi-OS Engine Plugin version did you use?

I am using the latest 1.3.1


Please try following steps:

  • Connect device to computer
  • Open IntelliJ and create Remote debug launch configuration, Port:8000
  • Open Terminal
  • cd ‘ios project’
  • ./gradlew moeLaunch -Pmoe.launcher.options=debug:8000
  • Run remote debug

Which IntelliJ IDEA version did you use? I tested with IDEA 2017.1.4 and worked fine.

Best Regards,

Hi Roland,

Sorry, it was my mistake, I had a local web server running on port 8000, once I turned it off, the debugger started working.

A good lesson for others who might have this problem :slight_smile:

Thank you.

Please remind me, how can I run the app from Xcode and then also attach from IntelliJ?
I need to pass some param somewhere in xcode, right?


Add the standard Java debug parameters to the Xcode command line:

Edit Scheme… -> Arguments Tab -> ‘Arguments Passed On Launch’

Best Regards,

Yeah, also need to run something from command line for real devices.
Found the full answer here: