Dex2oat cannot resolve a gazillion classes

Hi there,

I’m trying to build an iOS version of a libGDX based game, everything in the IntelliJ Idea side looks fine, but when I try to build it, I get tons of errors like these:

dex2oat W 10715 323995 /Users/rolandvigh/Migeran-1.3/aosp/art/compiler/driver/] Failed to resolve class Ljava/awt/Canvas;
dex2oat W 10715 324001 /Users/rolandvigh/Migeran-1.3/aosp/art/compiler/driver/] Failed to resolve class Ljava/awt/datatransfer/ClipboardOwner;
dex2oat W 10715 324000 /Users/rolandvigh/Migeran-1.3/aosp/art/compiler/driver/] Failed to resolve class Ljavax/swing/JPanel;
dex2oat W 10715 324002 /Users/rolandvigh/Migeran-1.3/aosp/art/compiler/driver/] Failed to resolve class Ljavax/swing/event/DocumentListener;

After peeking on these forums a little bit, I tried to add a proguard.append.cfg file to my ios-moe module with the following content, just to give it a try:

-keep class java.awt.** { *; }

But the XCode build continues complaining about classes inside the java.awt package not begin resolved.

Any ideas?

Thanks a lot in advance!

Well, forget this for now.

Most of those classes shouldn’t be there, it turns out it’s a small bug in libgdx that has recently been solved in the github source repository, though it seems there’s no published version to use with gradle which include that fix: