Error in Gradle Android Studio

I have a problem with sync my app with moe after create the moe module, and when sync the gradle i give this error, can one help me?

I tried re-download dependencies and stop the gradle build process but with not sucess.

Unable to find method 'org.gradle.api.tasks.compile.CompileOptions.setBootClasspath(Ljava/lang/String;)V'.
Possible causes for this unexpected error include:
Gradle's dependency cache may be corrupt (this sometimes occurs after a network connection timeout.)
Re-download dependencies and sync project (requires network)

The state of a Gradle build process (daemon) may be corrupt. Stopping all Gradle daemons may solve this problem.
Stop Gradle build processes (requires restart)

Your project may be using a third-party plugin which is not compatible with the other plugins in the project or the version of Gradle requested by the project.

In the case of corrupt Gradle processes, you can also try closing the IDE and then killing all Java processes.

dont work with new version of android gradle

Only work on gradle version 4.10.1 and plugin 3.3.2 or less


I have the same issue with Android Studio 3.4 with classpath’’. When I try to upgrade I get the same error.

1 Like

I have the same issue as well.

Android Studio 3.4.2
Build #AI-183.6156.11.34.5692245, built on June 27, 2019
JRE: 1.8.0_152-release-1343-b01 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0

My Gradle version is 3.4.1 and my MOE version is 1.4,3.