Feedback on MOE, and issues running applications


I’ve been having some issues with MOE…

I set up MOE version 1.2.4 on Windows with Eclipse and created some applications from the built-in templates. (I tried the ‘Single View Application’ and ‘Page Based Application’). Then I tried to remotely deploy to some devices (an iPod Touch 5 and an iPad Air 2).

The first issue I had was that I tried setting up the remote build using my Mac running OS X 10.10 (Yosemite) as the build machine. The documentation said the minimum supported version was OS X was 10.9 so I assumed it would be fine. But, this didn’t work. The temporary directory couldn’t be created because the command ‘mktemp -d’ was failing, apparently because it behaves differently on 10.10 to whatever OS X the MOE was tested on. I was able to work around this with a hack, but encountered a different problem, which looked like it was caused by XCode being too outdated. In the end I upgraded my Mac to Sierra and installed updates to XCode and after doing these things those issues went away.

The next issue I had was that I had to set ‘signing.developmentTeam’ in order for building to work. Given that the project wizard sets up all the other settings but misses this one out, and that it appears to be compulsory for the build to proceed, it seemed a bit non-intuitive. (I would like to suggest that the Eclipse project wizard be modified so that when you’re creating a new project inputting this information be compulsory.)

I also felt it was not obvious that the iOS device had to be connected to the Windows machine; I initially connected my devices to the Mac and then spent at least 10-15 mins wondering why my devices weren’t being picked up before realising that I had them connected to the wrong system.

Anyway after fixing all these things I was able to build the template application successfully and tried to deploy it to my devices. Now I thought things would be good, but I guess not :frowning:

Firstly, if I exit out of the application I just deployed and try to relaunch it from the home screen, both my iPod and my iPad lock up and crash; I’m not able to launch anything else either (e.g. Settings won’t open) and I’m only able to recover by using Home+Power to restart the entire device.

Secondly, I’ve encountered an issue where the debug server wasn’t running when I tried to launch from Windows, which apparently necessitated to try launching the application at least once from a Mac first. Seems like an enormous limitation; I assumed the biggest point of the remote build was to allow to build with, say, a Mac in a remote place… it doesn’t really work if you have to reconnect the target device to the Mac every time you have to restart it. So you need to fix this. I can work around it for now by deploying from my Mac, but at that point I may as well just develop the application on the Mac (as much as I detest using OS X and my Mac is garbage-speed worth of slow)

Finally, the iPod Touch 5 (running iOS version 9.3.2) works OK and I was able to get the app to start without any issue. But when I try to deploy to the iPad Air 2 (running iOS version 8.1.2) the app gets stuck at a blue screen. If I try iPad in the simulator, the app exits itself.

Honestly, I’m wondering whether I missed something with regards to configuring the project for iPads, given how non-obvious everything is and how much I had to meddle to get things even this far :confused: Is there something I need to change in the templates to get them to run?