I can't create ios executable in HelloWorld project

I tried Calculator example and simple HelloWorld app in Android Studio 2021.1.1 patch3 under Windows 7 and 10. My MOE settings in gradle is 1.7.+
No module shown in “edit configuration” . But all modules are visible in project structure menu.
Kotlin multiplatform is installed too, but I could not find how to remove it.


Are you aware, that for building a iOS App, you always need access to a MacOS system?
I think I ran in the same issue years ago, but I can check it later, whether I still get the same error. I never digged deeper into this in the past. But maybe following the guide fixes it.
Or you need to work on the macos host directly.

1 Like

Hmm. So creating iOS app under Android Studio is possible only on Mac OS machine? Correct?
I just followed instruction to create MOE app from here:

I got the same result as you on my local machine.
So it may be a bug in the Android Studio plugin or some remote build prerequisites that are missing.
I would recommend following this guide and checking whether this fixes it:

If this doesn’t fix anything you you could try to just use the plain gradle tasks and not the Android Studio plugin.
In the readme are some infos about remote build:

I newer worked with remote build so I can’t give any further info than just these maybe starting points.

1 Like

Unfortunately first type of remote build requires Mac machine. I don’t have it for now.
As for second suggested build type. I could not unserstand it.
It seems I really need Mac to create iOS build.

The second suggestion was just the same as the first one, but with the configuration done in gradle and not in the IntelliJ plugin.
But in any case, you always need a mac/mac vm to build for iOS.

1 Like

I got a MAC for a while. This is my first experience with the macbook.
No iPhone simulator in Run - Edit Configuration.
It seems Studio does not download it automatically.
And errors in gradle build:

  • unable to set SDK;
  • xcrun: unable to find utility “xcodebuild”, not a developer tool or in PATH
    It seems build is not so easy as I expected.
    I guess better to find some MAC emulator for Windows machine.

Have you XCode and XCode command line tools installed?

No. Unfortunately XCode requires upgrade from MacOs ver.11 to 12.
I will ask the owner about it.

You can still use Xcode 13.2 on Big Sur, if you download and install it manually.