MOE 1.3.0 released

We are pleased to announce the release of MOE 1.3.0. Most of MOE users already moved to the previous betas, if you are still on MOE 1.2.x, it is time to update now.

This is a companion discussion topic for the original entry at

Great stuff guys! Could you please clarify if common bindings project still require pod file and xcode steps in my own MOE project, or just adding one of the bindings as dependency is enough?

More specifically, do I only need to declare Crashlytics as dependency and skip all the steps except adding script file to MOE build to inject Crashlytics key?

Thank you

Hi Eugene,

you still need to include the native library, like before. You just don’t have to generate the Java bindings yourself. We decided to go this route, and not try to package the native parts (like in RoboPods), because this gives the app developer greater flexibility: he can choose whether he wants to use CocoaPods, Carthage or some other means to manage the native dependencies.

I will add this bit to the post for clarification.

Best Regards,

1 Like

Actually I just saw that I had this in the article:

Don’t forget to link to the native part of the library as well, e.g. using CocoaPods.

We will create a more detailed tutorial on how to integrate native libraries “soon” :slight_smile:

Good version, but for me the most importance now is the size of the IPA, i have post some idea here in the forum. About the size, MOE if far from Robovm. You should not ignore this, i read some where that this is not in the priority task.

My build stopped working since the release. 1.3.0-beta-2 works fine. The error is: Failed to apply plugin [id ‘moe’]. The exception message is: Couldn’t find the moe-gradle plugin in the classpath configuration.

I am on Windows and am using JDK 1.8.0_121 (64 bit), Gradle 3.4.1, Android build tools 25.0.2, and Android plug-in 2.3.0. I already tried downgrading both Gradle and the Android plug-in, but the same error keeps occurring.

I also tried disabling parallel builds, configuration on demand, and the Gradle daemon (at the same time), but that does not help either.

When I remove the MOE plug-in from the Gradle cache, version 1.3.0 is downloaded again, so Gradle is not using a beta version.

The Gradle debug output does not provide more information than the messages shown above.

What could be wrong?

Dear Johan,

We are currently looking into this. As a temporary workaround could you please try to move your classpath definition into the iOS module?

Best Regards,
Daniel Mihalyi

Okay we have released a hotfix for the gradle plugin (1.3.1). This bug should be fixed as of now.


It is working for me now. Awesome. Thanks a lot for the fast fix.

Which XCode version is supported with MOE 1.3?

MOE 1.3 support Xcode 8.x. To support Xcode 9.2, use MOE 1.4+