MOE 1.3 New Binding Unrecognised Selector UIKit.UIApplicationMain

Hi, I have successfully create the binding for googlemobileads frameworks(GoogleMobileAdsSdkiOS-7.20.0). However, I am getting the error as shown below.

the output directory for the binding creation is “src/”

WARNING: Binding class refers to class GADMobileAds, but it can not be found. Fallback to indirect super class.
2017-06-13 23:49:38.202 MyApp[2112:94622] +[NSObject configureWithApplicationID:]: unrecognized selector sent to class 0x6243028 +[NSObject configureWithApplicationID:]: unrecognized selector sent to class 0x6243028
at apple.uikit.c.UIKit.UIApplicationMain(Native Method)

public static void main(String[] argv) {
_ UIKit.UIApplicationMain(0, null, null, IOSMoeLauncher.class.getName());_

Best regards,

Problem been resolved.

May I ask how you solved it? I have been having the same problem.

1 Like


Are you using the official bindings from moe-bindings repo?

Best Regards,

How did you solve it? I have the exact same problem. @kisg I’m not using the official bindings. I downloaded the framework file from google ads and created by own nbc file. Should I try the one from moe-bindings repo?


yes, please try the official bindings. If you have any issues with those, let us know.

Best Regards,

1 Like

So, should I use that nbc file in official bindings with latest Google Ads SDK or should I use the whole google-mobile-ads-sdk folder in my project?

I tried with the Google Ads SDK downloaded and with the official bindings nbc file. I put the Ads framework file in Project/ios-moe/framework folder and tried to generate the bindings but I’m getting the same error as before:


May be it has something to do with Google changing the folder structure inside the framework and moe can’t find the required files?

Update: Anybody got a suggestion?

1 Like

Any luck with that error? Still trying to sort it out :confused: