No simulators, properties file not found after upgrade to Xcode 9 and 1.4.0 (using LibGDX)

Hello,

After not compiling/looking at the MOE part of our project since late 2017 (for various reasons), we would like to get back into our iOS port and finish it ASAP. It’s been a while since we last toyed with it, and in the meanwhile I moved from Xcode 8 to Xcode 9.

I followed the steps to upgrade MOE, changing the version to 1.4.0 and running ../gradlew moeUpdateXcodeSettings. I also ran ../gradlew clean and ../gradlew build, before finally opening the project in IntelliJ.

However, when editing the run configuration, I don’t have any simulators listed anymore :

03

Even though obviously, in my Xcode, there are tons of simulators available. What am I missing ?

Also, when trying to run the project, I’m getting this error :

Execution failed for task ':ios-moe:moeLaunch'.
/path_to_the_project/ios-moe/build/moe/xcodebuild/XcodeBuild-main-debug-iphonesimulator.properties (No such file or directory)

Any idea what’s wrong ? Did I miss a step, is there some extra configuring to do ?

(I have poor English)

Probably xcode build/signing error

may be able to get more info

(1)
create file

ProjectDir
+-- ios-moe
    +-- moe.remotebuild.properties

example

host=11.22.33.44
port=22
user=foo
identity=C:/moekey/ssh_priv_key.txt
knownhosts=C:/moekey/known_hosts
keychain.name=moeremotebuild.keychain
keychain.pass=bar
keychain.locktimeout=3600

(2)
ProjectDir> gradlew moeLaunch

So I should create this file, right ? But what should I fill in instead of the values you gave ? As host, as identity, etc. Is there any doc about this file ?

sorry. If use local xcode, the file seems unnecessary.

Is there not an error etc. with the following command?

./gradlew moeSDKProperties
./gradlew moeListSimulators
./gradlew moeLaunch
./gradlew moeLaunch -Pmoe.launcher.simulators=XXXXXXXXXXXX

https://github.com/multi-os-engine/moe-plugin-gradle#launch-task

example (device)

> gradlew moeListDevices

Connected iOS Devices:
- aabbcc0000000000000000000000000000000000

> gradlew moeLaunch -Pmoe.launcher.devices=aabbcc0000000000000000000000000000000000

“moe.remotebuild.properties” is Remote Build setting

https://github.com/multi-os-engine/moe-plugin-gradle#remote-server-settings
https://doc.multi-os-engine.org/multi-os-engine/3_getting_started/3_remote_build/remote_build.html

(no link, err: “new users can only put 2 links in a post.” )

Thank you, running these commands helped me narrow down several issues.

First the moeListSimulators command returned errors, until I plugged my iPhone in my Mac, which unlocked all the simulators. I have no idea why they were “locked” before, but as soon as I plugged the iPhone in (it’s a brand new one) simulators started appearing in IntelliJ, and the command stopped returning an error. Weird, but at least that’s one thing solved.

When I try moeLaunch, with my device plugged in, it successfully starts trying to installing it on the phone. However, I get stuck at this step :

Installing:
- [email protected]% CreatingStagingDirectory
- [email protected]% ExtractingPackage
- [email protected]% InspectingPackage
- [email protected]% TakingInstallLock
- [email protected]% PreflightingApplication
- [email protected]% InstallingEmbeddedProfile
- [email protected]% VerifyingApplication
> Building 95% > :ios-moe:moeLaunch

It never goes past this step. Any idea ?

When I try the moeLaunch with -Pmoe.launcher.simulators=XXXXXX with one of the simulators, it successfully installed and started the app on a simulator, so yay ! That’s great :slight_smile:

However, it’s totally fucked on IntelliJ. Neither with device or with simulator is working, I think the configuration is just screwed actually. Whether I try with simulator or device, I get :

/path_to_my_app/ios-moe/build/moe/xcodebuild/XcodeBuild-main-debug-iphoneos.properties (No such file or directory)

Intellij runs this command :

/Users/maxime/Documents/Games/OneTap/gradlew moeLaunch -Pmoe.launcher.options=no-build,no-install-on-target,config:Debug -Pmoe.launcher.devices=afdf405747afad492d42274328b2d3b13e991775

stuck at this step
VerifyingApplication

waiting for communication or process stop, or file system lock?
try,
unlock screen.
if exists, remove app from device.
iOS reboot.

XcodeBuild-main-debug-iphoneos.properties (No such file or directory)

Build errors or builds may be skipped.

try
./gradlew moeMainDebugIphoneosXcodeBuild
and Run using IntelliJ

IntelliJ Plugin (moe-ide-integration) may be 2 step.
(1) moeLaunch [no-launch, install-on-target] (build + install)
(2) moeLaunch [no-build, no-install-on-target] (launch only)

Unfortunately, trying to unlock the screen or reboot iOS did not change anything (the app does not exist on the device). Maybe there’s something badly configured with the Xcode projet ? Or the iPhone maybe ? Although from what I see, next steps should be 50% - CreatingContainer and 60% - InstallingApplication, so maybe there’s something wrong with the code itself, preventing from verifying it ?

As for IntelliJ, actually the latest MOE Plugin update solved the issue. It was discussed in another thread, and I can confirm that it was a problem with the plugin itself and the latest versions of Intellij/Android Studio. So I updated it, and it finally works. However, trying to moeLaunch on my device results in infinite loading/building, which I guess corresponds to the precise “VerifyingApplication” step when I build in Terminal. So there’s definitely an issue there. Last one to solve !

Thanks again for helping and sticking with me :slight_smile:

EDIT : I finally got it sorted. I managed to run the app on my device directly via Xcode (simply by running it there), and then when I tried running it in terminal again, it did not get stuck on the VerifyingApplication and worked. Finally ! Everything is functional now, thanks again for the help :slight_smile: