Not able to generate bindings anymore

I have not developed this in a while (about a year). I came back to it, and needed to upgrade MAC OS 10.15.4. XCode was also updated to 11.4, Android studio to 3.62. I updated the Multi-OS plugin to community 1.4.7, and changed ios build.gradle to classpath group: ‘’, name: ‘moe-gradle’, version: ‘1.5.0’. Project build.gradle is using 3.5.1

When I select Generate bindings, it prompts me for the NBC file name and creates it. There is no file (application) associated with NBC files any more, so when I double click on the NBC file, it does nothing. Is MOE still using generate bindings? If so, how do I get the Bindings dialog back?


I have an update. I was able to get it back to where I could edit an old NBC file, and the screen would display. So I created a NEW NBC file, and that one comes up asking how I want to associate the file.

See attached screen shot. MyNewListController was created a while ago. It shows the nbc editor. When I double-click on the new file (MainViewContoller.nbc), it prompts me to define the association.

Screen Shot 2020-04-15 at 11.47.13 AM

Any ideas?

Just select Text, close the text editor tab then double click the file again.

Thank you. Sorry for such a stupid question. I still cannot generate bindings.
I have tried downgrading XCode and Android Studio. I have tried both classpath group: ‘’, name: ‘moe-gradle’, version: ‘1.5.1’ and 1.50
I keep getting:

Task :ios:moeNatJGen
2020-04-18 10:10:26:931 -0600 [main] DEBUG - NatJGen started
2020-04-18 10:10:27:351 -0600 [main] DEBUG - Clang options: [-arch, arm64, -x, objective-c, -fmessage-length=133, -std=c99, -fobjc-arc, -fpascal-strings, -ferror-limit=9999999, -DNS_BLOCK_ASSERTIONS=1, -DOBJC_OLD_DISPATCH_PROTOTYPES=0, -isysroot, /Applications/, -miphoneos-version-min=9.0, -I/Users/davidkittredge/AndroidStudioProjects/iWish/ios/xcode/iWish, -I/var/folders/4m/4fvwtdy13113m49p5xfq2mkc0000gn/T/NatJGen416026941797629248, -iquote/Users/davidkittredge/AndroidStudioProjects/iWish/ios/xcode/iWish]
2020-04-18 10:10:27:373 -0600 [main] DEBUG - Indexing translation unit
2020-04-18 10:10:27:375 -0600 [main] DEBUG - Clang options: [-arch, armv7, -x, objective-c, -fmessage-length=133, -std=c99, -fobjc-arc, -fpascal-strings, -ferror-limit=9999999, -DNS_BLOCK_ASSERTIONS=1, -DOBJC_OLD_DISPATCH_PROTOTYPES=0, -isysroot, /Applications/, -miphoneos-version-min=9.0, -I/Users/davidkittredge/AndroidStudioProjects/iWish/ios/xcode/iWish, -I/var/folders/4m/4fvwtdy13113m49p5xfq2mkc0000gn/T/NatJGen416026941797629248, -iquote/Users/davidkittredge/AndroidStudioProjects/iWish/ios/xcode/iWish]
/var/folders/4m/4fvwtdy13113m49p5xfq2mkc0000gn/T/tempfile4651681148525092992.m:1:1: error: unknown type name ‘import’
2020-04-18 10:10:27:377 -0600 [main] DEBUG - Indexing translation unit
2020-04-18 10:10:27:379 -0600 [main] DEBUG - Generating classes
2020-04-18 10:10:27:380 -0600 [main] DEBUG - NatJGen ended in 0.448725419s

1 actionable task: 1 executed
/var/folders/4m/4fvwtdy13113m49p5xfq2mkc0000gn/T/tempfile4651681148525092992.m:1:8: error: expected identifier or ‘(’
/var/folders/4m/4fvwtdy13113m49p5xfq2mkc0000gn/T/tempfile4651681148525092992.m:1:1: error: unknown type name ‘import’
/var/folders/4m/4fvwtdy13113m49p5xfq2mkc0000gn/T/tempfile4651681148525092992.m:1:8: error: expected identifier or ‘(’

The temp file simply shows
import “SideMenuViewController.h”

#import "SideMenuViewController.h"