Problem with ios-moe, libgdx and Box2d

Hello! I am sorry for my bad English. My problem is this:

I’m developing the game using the libgdx framework and I need to test the code on iPhone. I’m run my game using XCode on my iPhone and it’s working. But when I try to go to the scene of the game where Box2D is used, the game fails. I know that the problem is with the initialization of the box2d world, because when I remove the lines of code responsible for creating the world, everything works. I could not find information about this problem in the Internet, so I ask the question here, I’m not sure that this is correct, so the same question was asked also at the Libdx forum. What can be the problem, what are the solutions?

Thank you.


Can you provide us with a test project to reproduce this?

Best Regards,

Try running your project on your phone through android studio / intellij then you could see the error log & stacktrace.

I already tried to run the project in Android Studio and get error message in console:

Configuration on demand is an incubating feature.
Using already downloaded SDK: /Users/alexanderzimin/.moe/moe-sdk-1.4.0
:ios-moe:moeLaunch FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:ios-moe:moeLaunch’.

/Users/alexanderzimin/Programming/libGDX/Games/libGDX-50/ios-moe/build/moe/xcodebuild/ (No such file or directory)

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.


What is mean?

What do you mean by providing a test project? Do I need to attach an archive or a link to a remote repository?

Have you tried to update moe version? What’s your current moe version and xcode version?

Current version of XCode is 9.2 (9C40b), moe is 1.4.0 and 1.4.2 (these folders are in /Users/alexanderzimin/.moe/). There can be a problem in this? Most likely, the assembly happens using the old version of mine, how do I specify a newer version?


Please check: /ios-moe/build/moe/xcodebuild/XcodeBuild-main-debug-iphonesimulator.log
Contain “Undefined symbols” error?

Best Regards,

Hello, there is no XcodeBuild-main-debug-iphonesimulator.log file in the folder /ios-moe/build/moe/xcodebuild, but there is a XcodeBuild-main-release-iphoneos.log file and this file is empty. What do I need to do to the file you specified?

Hello Alexander, did you find a solution for using box2d on ios?