Problems with 1.3.0 upgrade

Having a few problems with the upgrade to 1.3.0, what I found so far which are blockers:

  1. java.lang.RuntimeException: java.lang.NoClassDefFoundError:

  2. java.lang.IllegalStateException: missing metadata: /com/google/i18n/phonenumbers/data/PhoneNumberMetadataProto_IL

I will update if I find more issues…

What can I do about these two?

Hi Alex,

wherer exactly do you see these errors? Are you using the 1.3.1 Gradle plugin (we had to release a hotfix of it)?

Best Regards,

I get them at runtime.

I used 1.3.+ in the build.gradle

We are looking into this. Can you provide us a test project? We have not seen these issues during our tests and sample apps.

That will take time, but I will try. To save us both time you are always welcome to connect to my machine and see.

Does the proguard.append.cfg still work?

Both problems look like a proguard issue, the first one looks like is missing this class:

I tried adding this:

-keep class {}

to the proguard.append.cfg file under my MOE module but it didn’t help

I tried creating a sample project that uses OkHttp but it seems to work… I guess it’s more complicated than that.
For some reason the error stack trace (in our app) shows instead of com.squareup.okhttp