Remote build stopped working after project.pbxproj change


Porting my libgdx android app to moe is going nicely. I’d say 95% of the functionality worked out of the box. I love the remote build functionality, was doing everything from my main Windows machine.

One of the things that didn’t work was sound. It turned out that the gdx-setup jar I used to generate my ios-moe project was old, and this pull request from RolandVigh fixed the gdx-setup tool to make a change in how assets were handled, solving the sounds not working issue:

So updated my build.gradle and project.pbxproj files according to that commit and ran the project from Android Studio on my mac mini and it fixed the sound problem. Great.

Then I tried to use remote build again and got this error (full error:

The following build commands failed:
CpResource /var/folders/3m/w6hp3w5n74d8nyybwm9sd7840000gn/T/android/assets /var/folders/3m/w6hp3w5n74d8nyybwm9sd7840000gn/T/tmp.vgc3fnN5/build/moe/xcodebuild/Debug-iphoneos/Bluff\

(1 failure)

This copy action seems to grab the assets folder from a wrong location because the entire project should be in the /var/folders/3m/w6hp3w5n74d8nyybwm9sd7840000gn/T/tmp.vgc3fnN5 folder.

But I can’t even seem to find the assets folder at all in that tmp.vgc3fnN5 folder. I also made a new project with the new gdx-setup tool and got the exact same error there.

Full source of new generated project that has this problem:

TLDR: So any clue how to include the assets in the remote build with a project generated from the latest gdx-setup??

I can probably duplicate the assets and put them in the same folder as the ios specific images to make it work. But it’s not an ideal solution as they would be in git twice.


While we are working on this error, please open project xcode and remove assets reference and add removed line to build.gradle file:

sourceSets.main.resources.srcDirs = [ file("../%ASSET_PATH%") ]

Best Regards,


We released gradle plugin 1.3.12. Added new remote build option.
Please add new settings to build.gradle:

moe {
    remoteBuild {
        resources = [ file("../android/assets") ]

Best Regards,

1 Like


Libgdx merged pull request

Best Regards,

Sounds good. Will test when I get home!

It seems to work fine now, thanks!