Home Features Docs Blog Support GitHub

Failed to populate list of simulators


#7

Could you share your IDE log?


(Eduardo Vital) #8

I am not sure which log to share. If I try to run the project the log is related to the absence of emulators:

Preformatted text:moeLaunchInvalid UDID string ‘’.

If I open the Run/Debug Configurations the following error within a pop-up appears:

Failed to populate list of simulators


(Andrii Meretskyi) #9

Wow. Awesome, thanks! Will wait for fix.
For now I use Xcode 10.3 . Able to debug app. To change simulator device I modify .idea/workspace.xml.


#10

In your Intellij/AS, open the Run/Debug Configurations dialog, make sure the error is popped up (if not, just reopen your project), then click the “Help” menu then “Show log in Finder(Explorer?)” and attach the file (make sure to remove any sensitive data from the log, or just copy-paste the part around the last stack trace).


#11

The error persists even after switching back to Xcode 10.3?


(Andrii Meretskyi) #12

Yes. I think it is because I have latest Android studio installed. I am not able to modify configuration. I still see “Failed to populate list of simulators” when I open Edit configuration window. Also not able to save configuration. It says that I need to select module. But modules dropdown is empty. I thought it is what your version is also going to fix. But I have two XCode versions now. So maybe that`s the reason.


#13

Interesting… Could you also send me a copy of your Android Studio log?


#14

#16

Could you try this and see if that solve the problem?


(Eduardo Vital) #17

Yeah, the plugin solved. By the way, I didn’t know that there was a Community Edition of the plugin, as soon as I removed the legacy one and installed the Community Edition everything worked. Thanks!


(Andrii Meretskyi) #18

Thanks!
I updated plugins and now I can chose and change device. Also I leaved only XCode 11 and debug works from AS.

There is only one issue left. When I change simulator and save configuration I still see error “Please select a module”. It is not urgent since device is updated in config. Log attached. 07%20PM idea.log (1001.5 KB)


#20

Ok I did find an issue in this plugin and I’ll make a fix ASAP.


(Andrii Meretskyi) #21

I happy that MOE got a new breath with community. Unfortunately I do not have a time to participate yet. But I can help with issue reporting :slightly_smiling_face:.


#22

Ok for now a temporary solution is go to Preference -> Build, Execution, Deployment -> Gradle, select

Generate *.iml files for modules imported from Gradle

then reimport the gradle project, and the plugin should start working again. I’ll make this option selected by default in the next release.

image


MOE Intellij & Gradle Plugin Community Edition release 1.4.6 - Xcode 11 support
(Andrii Meretskyi) #23

Weird. I do not have this option
51%20AM


#24

Could you send me the ‘.idea/gradle.xml’ file in your project?
Also you could try deleting this file, then select File -> Sync Project with Gradle Files, then select File -> Invalidate Cache / Restart -> Invalidate and Restart and see if that solves the problem.


(Andrii Meretskyi) #25

gradle.xml (634 Bytes)

It did not help.


#26

Could you try:

  1. Right click the root project
  2. Select Refresh Gradle project
    image
  3. Then
    image

(Andrii Meretskyi) #27

Wow. This one worked!

Also there is one more thing in MOE after updating to latest XCode. After generating bindings in some classes I see build error: “cannot find symbol class Block_modifyAnimationsWithRepeatCountAutoreversesAnimations”. So every time I remove generated modifyAnimationsWithRepeatCountAutoreversesAnimations method.
50%20AM


#28

Well to fix this require rebuild the SDK against the latest iOS SDK which I currently don’t have much free time to do (and properly test it). So I guess you just have to delete it every time you generate a new binding :stuck_out_tongue_winking_eye: