Home Features Docs Blog Support GitHub

MOE Intellij & Gradle Plugin Community Edition release 1.4.6 - Xcode 11 support


#1

In order to support Xcode 11 simulator, you must update BOTH the gradle plugin and Intellij/AS plugin!

If the plugin can’t find the module or the right click menu is greyed out, try the solution here:


It’s a known issue caused by the changing of Intellij/AS project file structures and a proper fix will be included in a future release.

Change log:

Intellij/AS plugin:

  • 1.4.6
    • Fix “Failed to populate list of simulators” error with Xcode 11
    • Increase minimum supported IDE version to 2018.x.
  • 1.4.5
    • Initial release of the community edition
    • Remove maven support
    • Fix “Open Project in Xcode” when multiple Xcode versions are installed
    • Use MOE gradle plugin community edition for new project

First uninstall the original Multi-OS Engine Plugin from your AS/Intellij. Then install Multi-OS Engine Community Edition from marketplace.
NB: Someone might find it to be appeared as 1.4.5 in Android Studio plugin marketplace screen but if you just install it you will get the latest version (1.4.6). Strange bug. :stuck_out_tongue:

Gradle plugin:

  • 1.4.6
    • Fix Xcode 11 simulator launching

Simply change you build script to use the new plugin:

buildscript {
    dependencies {
        classpath group: 'org.multi-os-engine.community', name: 'moe-gradle', version: '1.4.6'
    } 
}

MOE Update #1: Reviving the Multi-OS Engine Project - Multi-OS Engine
Failed to populate list of simulators
Failed to populate list of simulators