Problem running moeUpdateXcodeSettings

I am getting “Xcode project is not up to date, update it with task moeUpdateXcodeSettings” during a build. I then try to run “./gradlew moeUpdateXcodeSettings -Pmoe.forced.update”, but I get the following error:

Error:FAILURE: Build failed with an exception.

  • What went wrong:
    Task ‘./gradlew’ not found in root project ‘MyProject’.

It does indeed look like gradlew is in the root of the project. I’m running it from the “Execute Gradle Task” button in the gradle projects tab. Is this the correct place to do so?

The issue that has me trying to run these is because I created a UIViewController in java, but when I open the project in Xcode, I cannot find a corresponding .m file to wire up Outlets and Actions in.

1 Like


Please try

../gradlew moeUpdateXcodeSettings -Pmoe.forced.update

Generated ui-headers location: …/build/moe/main/ui-headers/moe-main-interfaces.m
or in Xcode project: Multi-OS Engine/moe-main-interfaces.m

Best Regards,

Thank you Roland. I ended up running it from terminal instead of from “Execute Gradle Task” within AndroidStudio. It worked successfully when I ran it in terminal.

Can I ask what the proper workflow should be for using an Xcode Storyboard? I wonder how to wire-up outlets and actions in Xcode, but then have that code translated back to MOE so that I can do the java programming in MOE. In the past, we used Synchronize to Java and it took our outlets and actions and update the java code with any needed changes. How should we do this now?

1 Like