Home Features Docs Blog Support GitHub

Version 1.4.1 - No value has been specified for property 'bundleIdentifier'


(Alex Itelman - Muvix) #1

Hi, when upgraded gradle plugin from 1.4.0 to 1.4.1 I’m getting an error in gradle build (IPA):
No value has been specified for property ‘bundleIdentifier’

Do I need to update something? Are there migration steps?


(Roland Vigh - Migeran) #2

Hi!

Which xcode version are used? Are you opened project in the xcode, Bundle Identifier is empty?

Best Regards,
Roland


(Alex Itelman - Muvix) #3

Xcode 9.1.
In Xcode Bundle Identifier is not empty.


#4

The “PRODUCT_BUNDLE_IDENTIFIER” key doesn’t appear in ‘./build/moe/xcodebuild/XcodeBuild-xxx-xxx-xxx.properties’ which is required by here:


#5

Alright it turned out that the bundle identifier is hardcoded inside info.plist instead of PRODUCT_BUNDLE_IDENTIFIER in .xcodeproj file.

After adding this value in .xcodeproj file peoperly, it should fix this issue.

image

image


(Alex Itelman - Muvix) #6

Unfortunately this is not working for me, it brings back the original problem that I had for which I removed the Bundle Identifier from the xcodeproject and it solved it, has to do with code signing, it was a workaround for a problem when xcode project signing is set to automatic, but in the gradle build script I must specify the provisioning profile manually (otherwise it’s not being signed with the distribution key, so I can’t upload to app store).

The specific error is:

Code Signing Error: [***] has conflicting provisioning settings. [***] is automatically signed, but provisioning profile [***] has been manually specified. Set the provisioning profile value to “Automatic” in the build settings editor, or switch to manual signing in the project editor.
Code Signing Error: Code signing is required for product type ‘Application’ in SDK ‘iOS 11.1’


(Alex Itelman - Muvix) #7

Actually this seems to be working fine with this version if I do what you suggested and remove the signing identity in the gradle build script.


#8

Yeah if the Automatic mode works for you, then you should only specify the dev team in your gradle