Debugger is stuck on launch when running from IntelliJ


I sometimes run my MOE project from Xcode and sometimes from IntelliJ, depending on which part I want to debug.
When I run from Xcode everything is fine.
But from IntelliJ the app stuck on the launch screen and the console says “waiting for debugger to connect”.

I am running on a real device

Hi Alex,

Just to double check: are you running MOE 1.2.4 SDK and the MOE 1.2.1 IntelliJ plugin with Xcode 8.1?

Did you do any customization to your app startup in Xcode (e.g. hardcoded the JDWP debug port so you can connect to it from IntelliJ after starting from Xcode)?

Does this happen every time you try to start the app from IDEA? During our testing we did see this very rarely (1-2 times in total), but after retrying it always worked.

Can you share us the IDEA log (Help -> Show Log in Finder)?

Best Regards,

Hi Gergely,

Sorry for replying so late, I was busy with other stuff and didn’t notice your reply.

Yes, these are the correct versions, although we are using 1.2.+ , like in your sample, in our gradle script so I’m not sure which exact minor version it is taking.

I didn’t do any customization in app startup in Xcode.

Yes, this happens every time.

This forum doesn’t allow me to upload attachments! (new users can’t upload logs).
So you can see the log here:

Best Regards,


Could you please set your log level to DEBUG in <IDEA_HOME>/bin/log.xml and resend the log?


Is this good: (5.8 KB)


We didn’t get much from this log, but the good news is that now on one of our developers’ machine we could reproduce the issue, so we can work on a fix.

Thanks for reporting this.

Dear Alex,

please try to update to IDEA 2016.3.1. We also had issues with 2016.3.

Best Regards,

I am actually using 15.0.2 …

Still happening in 2016.3.1 … Any news on this?

Any help would be appreciated

This is also happening with a new vanilla MOE project.

Sometimes it causes the entire phone to be stuck on the app launcher, it doesn’t even respond to home button presses, like what happens to some of our customers in this bug:

We are testing with 2016.2 and 2016.3.1 and we don’t see this issue at all (or the other one).

What is the OSX and the iOS version + exact device model?

OSX 10.11.6 (15G31)
iOS 10.2.1
Device iPhone 5s.

This happens consistently on my machine. Do you want to connect remotely and check it out?

Dear Alex,

do you also experience this issue when running our Calculator sample?

Best Regards,

I don’t know, can you drop me a link to the sample?

Yes, it is happening on the Calculator sample.
BTW, it doesn’t happen on the simulator. Only on real device.

Dear Alex,

about how much time does it take for IDEA to upload the app onto your device and then launch it? A console in IDEA should appear when this starts to happen. Could you please measure it?

Best Regards,

Just a few seconds…