Multi-OS Engine Release 1.1.0

We are pleased to announce the Multi-OS Engine 1.1.0 release.

The highlights include:

  • Android Studio / IDEA plugins are distributed from the JetBrains plugin repositories
  • The MOE Gradle plugin is now on JCenter
  • The SDK is automatically downloaded from Maven
  • Improved Simulator Launcher
  • … and more!

For more details and release notes check out our announcement blog post.

To get started just follow the setup instructions.



Amazing! Thank you so much for the hard work!!!

Awesome! Testing right now, thank you!

1 Like

Hi sorry. I think there’s some things wrong with my internet. Is there anyway that I can force the Android Studio to download the SDK again ? I tried uninstall that two plugins but… look like it will not remove the SDK as well.


or provide a link to download the SDK ?


Dear Ivan,

There are a few directories which affect the SDK, but let me make sure you’re applying the new MOE plugin correctly.

In your MOE module’s build.gradle file please make sure you are referencing the new version (1.1.+) of MOE.

buildscript {
    repositories {
    dependencies {
        classpath group: 'org.multi-os-engine', name: 'moe-gradle', version: '1.1.+'

The MOE SDK by default is installed here: ~/.moe/moe-sdk-1.1.0, if you can see this directory, that means the SDK setup was successful.
If you can only see a ~/.moe/moe-sdk-1.1.0.tmp directory, that means the MOE SDK installation failed. To get more information on the failure open Terminal, go to the directory of your project and execute ./gradlew tasks -s, if the SDK installation fails again it should print out a stacktrace of where it failed.
If you can’t eve see the ~/.moe/moe-sdk-1.1.0.tmp directory, that means installation of the MOE SDK was never attempted. There can be two reasons to this:
1, No projects ever tried to use MOE SDK 1.1.0
2, Download of the SDK failed of the downloaded file is corrupted, in this case you can check for the following directory: ~/.gradle/caches/modules-2/files-2.1/org.multi-os-engine/moe-sdk/1.1.0, try deleting this directory and retry

I assumed you are working on a Mac, if this is not the case or further assistance is needed, we’ll be happy to help you out!

1 Like

Great! Thanks for tips! I managed to find the folder, removed it. and create another new ios project just to force it re-download the SDK again.

it works great now! Thanks! :grinning:

A post was split to a new topic: Problems with MOE UI Designer and Xcode UI Design


You are having same problems as mine. you can refer my questions. He had solved a lot of my questions :heart_eyes: