Bit not clear on one of the UI tutorial

in this tutorial, “Creating a UI Using an Apple Xcode Storyboard” step No. 10

Step 10: Drag a new ViewController and select the newly created MyViewController in the highlighted section.

When drag a new ViewController control over, I can;t find a way to select back the previous newly created “MyViewController”

Am I miss any steps or…

Any help ? :sweat_smile:


Dear Ivan,

I’m not quite sure where you have the issue. Please try the following:

If you cannot find your MyViewController in the dropdown menu at step 4, please try to re-open the storyboard file.

YES! Thanks again! I think this picture are more clearer than the tutorial one.
Missing part will be No.3 and No.4. not quite clear in tutorial.
Sorry, I’m not quite familiar with Xcode. I’m from Eclipse world.

Just wanted to clarify, No.3, I need to rename it ?

Thanks again.

Dear Ivan,

You shouldn’t need to rename it, after selecting the value in step 4, it should rename itself.

1 Like

ok. got it. I think the No.3 can be ignore or switch with No.4. means… No.4 should be No.3 and No.3 became No.4

Thanks again! :grinning:

Thanks, I’m getting quite close except the import section…
but another question, once I go back to Android Studio. pointed at my iOS project and do a right click.
click Multi-OS Engine Actions but there’s no “Synchronize to Java” option…

I’m so sorry…

or I should select Generate bindings instead ?

Dear Ivan,

You need to select a header file (*.h) for this option to be available. At step 8 you created two files, MyViewController.m and MyViewController.h, you need to right-click on MyViewController.h. Depending on where you saved it, it may be under build/xcode/<projectname>.

Hi again…I’m so sorry…

Still no “Synchronize to Java” option for me…

as the picture below…

and this is my header file :

Dear Ivan,

The guide doesn’t specify where to save the Cocoa Touch Class files. The default location Xcode’s save panel provides should be build/xcode/<projectname>. The menu should be available here.

i see…ok, got it! thanks!


I’m so sorry…am I miss some things again ?

This is the error i got.

and in Step 5. It said remove ixml file in layout folder, right ?

Step 5: In the project structure find and delete the files AppViewController, MainUI.storyboard and the folder resources/layout - you will regenerate them after designing the UI in the Xcode Interface Builder.

but after the Xcode and return back to Android Studio. I don’t see any where it auto generate the ixml file…

so sorry…

a… now I can’t even open the project in Xcode…

Any ideas ?

Dear Ivan,

You get this error, because there is a layout folder, but there aren’t any ixml files in it. Please remove the layout folder too.

Hi Kristóf Liliom,

you are so amazing. really a big thanks to you…

I had removed the layout folder but look like it did not auto generate all the required files.
I can open the project in Xcode now but it did not re-generate the layout folder.

I’m so sorry… but really thank you for all your help.

Thanks again

ok, even I start another project. removed Layout folder. done all the required in Xcode.

come back , it still won;t re-generate the layout folder.
Now, my header file auto removed. haha am not sure what happen…

but I still can open my project in Xcode. I just can’t run it in iOS.

you can see my problems from the following picture. really appreciate your help

Thanks again

ok, I removed all the MyViewController.h and m files. removed storyboard as well.

Open project in Xcode. Do every things again.
Sync to Java.

there’s still no Layout folder re-generated.

now I can run the iOS app but show me black screen with black colour background.

Any ideas? so sorry


Finally I know why my header files auto removed… because I rebuild the project.

ok, but the problem still there. Create new project but Layout folder still not re-generate…

I’m still stuck at there…