Failed to populate list of simulators

After I installed Xcode beta 11, I got this error “Failed to populate list of simulators”.

Then I uninstall Xcode beta 11 and now only have Xcode 10.3 and the command-line tool is already installed. But I still get that error. How can I fix it? Thank you.

I was hitting this issue myself. Looking in the Intellij logs, I found a failed command involving xcrun simctl. Stack overflow then told me this:

Once I manually set the command line tools (and wow, is that a silly thing to have to do…) my simulator list started populating.

Hope that helps!

Not help for me. Command line tools was already set in settings.
Android Studio 3.5
Multi-OS Engine Plugin v1.4.4-C
XCode 11

A fixed version has been uploaded and pending JetBrains’ approval. It should be available in a few days.


I also had the same problem. Even downgrading to XCode 10.3 the problem persists. Any help?

Could you share your IDE log?

I am not sure which log to share. If I try to run the project the log is related to the absence of emulators:

Preformatted text:moeLaunchInvalid UDID string ‘’.

If I open the Run/Debug Configurations the following error within a pop-up appears:

Failed to populate list of simulators

Wow. Awesome, thanks! Will wait for fix.
For now I use Xcode 10.3 . Able to debug app. To change simulator device I modify .idea/workspace.xml.

In your Intellij/AS, open the Run/Debug Configurations dialog, make sure the error is popped up (if not, just reopen your project), then click the “Help” menu then “Show log in Finder(Explorer?)” and attach the file (make sure to remove any sensitive data from the log, or just copy-paste the part around the last stack trace).

The error persists even after switching back to Xcode 10.3?

Yes. I think it is because I have latest Android studio installed. I am not able to modify configuration. I still see “Failed to populate list of simulators” when I open Edit configuration window. Also not able to save configuration. It says that I need to select module. But modules dropdown is empty. I thought it is what your version is also going to fix. But I have two XCode versions now. So maybe that`s the reason.

Interesting… Could you also send me a copy of your Android Studio log?

1 Like

Could you try this and see if that solve the problem?

Yeah, the plugin solved. By the way, I didn’t know that there was a Community Edition of the plugin, as soon as I removed the legacy one and installed the Community Edition everything worked. Thanks!

I updated plugins and now I can chose and change device. Also I leaved only XCode 11 and debug works from AS.

There is only one issue left. When I change simulator and save configuration I still see error “Please select a module”. It is not urgent since device is updated in config. Log attached. 07%20PM idea.log (1001.5 KB)

Ok I did find an issue in this plugin and I’ll make a fix ASAP.

1 Like

I happy that MOE got a new breath with community. Unfortunately I do not have a time to participate yet. But I can help with issue reporting :slightly_smiling_face:.

Ok for now a temporary solution is go to Preference -> Build, Execution, Deployment -> Gradle, select

Generate *.iml files for modules imported from Gradle

then reimport the gradle project, and the plugin should start working again. I’ll make this option selected by default in the next release.


Weird. I do not have this option