Problem with moe + cocoapods

in my libgdx game, I’m Tring to implement Google-Mobile-Ads-SDK using cocoapods.
I have done new binding and installed pod following this post: Help with the “Create New Binding” option in 1.3.x plugin
My app now build and work correctly in Android, but in IOS environment, when my app starts, I’m getting this error:
art E 20466 1189828 /Users/rolandvigh/public-repo/aosp/art/runtime/] No implementation found for long (tried Java_com_badlogic_gdx_graphics_g2d_freetype_FreeType_initFreeTypeJni and Java_com_badlogic_gdx_graphics_g2d_freetype_FreeType_initFreeTypeJni_)_

Before to implement cocoapods all worked fine also in Ios

What could be the problem?


Also please notice if anything like
occurred when you add cocoapods.

Yes, but I solved this adding
#include “…/Pods/Target Support Files/Pods-ios-moe/Pods-ios-moe.debug.xcconfig”
#include “…/Pods/Target Support Files/Pods-ios-moe/Pods-ios-moe.release.xcconfig”
in my xcode/ios-moe/build.xcconfig

I also tryed to

“add include to pod xconfigs: #include “…/…/…/[xcode name]/custom.xcconfig””

but without results

this is my situation


AFAIK, normally there will be 3 xcconfig in your project if you use libgdx + cocoapods:

  1. custom.xcconfig which is used by libgdx to link libgdx’s native libs.
  2. Pods-[xcode nam].debug.xcconfig
  3. Pods-[xcode nam].release.xcconfig

2 and 3 are generated by cocoapods.

I have no idea where your build.xcconfig came from.

Before you add cocoapods support, your libgdx project should only have custom.xcconfig which is referenced from your xcodeproj.

After you add cocoapods, your xcodeproj should references Pods-[xcode nam].debug.xcconfig in debug config and Pods-[xcode nam].release.xcconfig in release config. But since your project already use custom.xcconfig that’s why you will get warning like this:

It suggests you to include Pods-[xcode nam].debug/release.xcconfig in custom.xcconfig but it’s usually a better idea to do in the opposite: include custom.xcconfig in Pods-[xcode nam].debug/release.xcconfig because the xcconfig for pods have two different configs (debug and release) and custom.xcconfig is shared between both two build configs. You can’t include xcconfigs for different build configs in the same file. Further more, the content of custom.xcconfig is generated during build process by libgdx (see here).

Here is an example (using the sample libgdx project from here):

  1. Select the correct config for debug & release configs:
    (Remember to add these two xcconfig files to your main project like highlighted on the left side.)

  2. Include custom.xcconfig in those files:


Thank you very much! Now works like a charm.

What’s more, if you run pod install / update, those modifications you did in Pods-[xcode nam].debug/release.xcconfig will be overwritten by pod. Make sure to get them back (via git for example) after any pod update.